visual studio 2017编译运行出现脚本发生错误等问题如何解决?


升级VS2017后,编译运行程序会出现 /Community/Common7/IDE/PrivateAssemblies/plugin.vs.js 错误

先说VS2017-15.6.1跟旧版本IE的兼容问题

首先我的IE比较旧,是IE9.0.8112,这个主要是为了在开发时测试页面、JS脚本跟旧版本IE的兼容及显示问题的。但是IE跟JS之间一直是比较“暧昧”的,MS一遍在推广自己的JS架构,一边在浏览器对象间跟谷歌各自搞一种套路。这些都是背景。

当我用VS2017进行调试时,弹出了这样一个框:

问题解决方法

手动到 \Common7\IDE\PrivateAssemblies\plugin.vs.js 把文件名随便改一下,就可以了。

弹出别的脚本错误,也是一样处理。


免责声明:

本站提供的一切软件、教程和内容信息仅限用于学习和研究目的;不得将上述内容用于商业或者非法用途,否则,一切后果请用户自负。本站信息来自网络,版权争议与本站无关。您必须在下载后的24个小时之内,从您的电脑或手机中彻底删除上述内容。如果您喜欢该程序,请支持正版,购买注册,得到更好的正版服务。如有侵权请与我们联系处理。敬请谅解!

点赞

发表评论

电子邮件地址不会被公开。必填项已用 * 标注